Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> Brak pliku .dll, problem
plejaz
post 4.07.2018, 14:05:57
Post #1





Grupa: Zarejestrowani
Postów: 35
Pomógł: 0
Dołączył: 10.01.2010

Ostrzeżenie: (0%)
-----


Witam, przy próbie instalacji oprogramowania opencart na serwerze Xampp zainstalowanym na windowsie wyskakuje mi błąd dotyczący braku rozszerzenia.
Treść błędu jest następująca: mCrypt extension needs to be loaded for OpenCart to work!
Znalazłem kilka poradników w internecie, ale większość dotyczy Linuxa, a rozwiązanie z pobraniem gotowej biblioteki zawierającej to rozszerzenie nie przynosi rezultatu mimo zastosowania się do wszystkich wskazówek.
Wersja php: 7.2.6

Ten post edytował plejaz 4.07.2018, 14:09:35
Go to the top of the page
+Quote Post
viking
post 4.07.2018, 14:11:20
Post #2





Grupa: Zarejestrowani
Postów: 4 877
Pomógł: 827
Dołączył: 30.08.2006

Ostrzeżenie: (0%)
-----


A dokumentację czytał?
http://php.net/manual/en/intro.mcrypt.php

Cytat
Warning

This feature was DEPRECATED in PHP 7.1.0, and REMOVED in PHP 7.2.0.

Alternatives to this feature include:

Sodium (available as of PHP 7.2.0)
OpenSSL


--------------------
Go to the top of the page
+Quote Post
Pyton_000
post 4.07.2018, 14:32:50
Post #3





Grupa: Zarejestrowani
Postów: 7 428
Pomógł: 1313
Dołączył: 26.10.2005

Ostrzeżenie: (0%)
-----


https://github.com/phpseclib/mcrypt_compat
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 22.07.2018 - 11:28