Pomoc - Szukaj - Użytkownicy - Kalendarz
Pełna wersja: Błąd 404 przy połączeniu przez SSL
Forum PHP.pl > Forum > Serwery WWW > Apache
romseb
Hej wszystkim

Mam skonfigurowany apache do pracy z SSL. Kontrola składni httpd.conf nie wykazuje błędów, logi apache też nie, A przy próbie połączenia ze stroną w https dostaję komunikat, że nie znaleziono hosta, czyli błąd 404. Pytanie do was, co jeszcze sprawdzić, aby https zaczął działać. Nazwa hosta w virualhost jest prawidłowa. Działa to na zasadzie: virtualhost z portem 80, virtualhost z portem 443, i rewritecond w dofinicji virtual hosta 80, w telu wymuszenia https. Będę wdzięczny za wszelką pomoc.

Pozdrawiam
romseb
Tomplus
Przykład działającej konfiguracji Apache dla SSL stworzonego przez Let's Encrypt.
Kod
<IfModule mod_ssl.c>
  <VirtualHost *:443>
        ServerName domena.pl
        ServerAlias www.domena.pl
        ServerAdmin webmaster@domena.pl
        DocumentRoot /home/www/websites/katalog_strony/

        <Directory /home/www/websites/katalog_strony>
                Options FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                Require all granted
                allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/domena.pl.error.log

        LogLevel notice

        CustomLog ${APACHE_LOG_DIR}/domena.pl.access.log combined
        SSLCertificateFile /etc/letsencrypt/live/domena.pl/fullchain.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/domena.pl/privkey.pem
        Include /etc/letsencrypt/options-ssl-apache.conf
  </VirtualHost>
</IfModule>
To jest wersja lo-fi głównej zawartości. Aby zobaczyć pełną wersję z większą zawartością, obrazkami i formatowaniem proszę kliknij tutaj.
Invision Power Board © 2001-2021 Invision Power Services, Inc.