Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

4 Stron V  « < 2 3 4  
Reply to this topicStart new topic
> [linux]APACHE2+SSL+MOD_REWRITE+CGI +PHP4+PHP5+MySQ
Fo
post 22.12.2006, 21:02:35
Post #61





Grupa: Zarejestrowani
Postów: 401
Pomógł: 0
Dołączył: 18.04.2003
Skąd: Trójmiasto

Ostrzeżenie: (0%)
-----


hmm a czy wykonałeś może make clean po tym jednym błędnym razie kiedy nie zdefiniowałeś wszystkich potrzebnych parametrów ?

make clean zczyszcza to co wykonywałeś poprzednio. jak wykonasz raz błędny make, przerwiesz go i później wykonasz drugi make już z innymi parametrami, to takie kwiatki mogą się pojawiać.

Jeżeli wiesz to co napisałem, to wybacz, nie miałem chęci pouczać Cię z podstaw.

Uśmiechniętego karpia życzę,
Fo
Go to the top of the page
+Quote Post
sebastianzar
post 10.08.2007, 03:12:37
Post #62





Grupa: Zarejestrowani
Postów: 2
Pomógł: 0
Dołączył: 31.05.2007

Ostrzeżenie: (0%)
-----


witam faktycznie po instalacji mysql i resecie kompa wyskakuje socket = /tmp/mysql.sock ale w tym przypadku wystarczy odpalic jeszcze raz mysqld_safe i wszystko gra jesli chodzi o caly opis copilacji to mysql i ssl oraz apacze instaluje sie bez bledow pierwsze bledy pojawiaja sie juz przy samej instalacji mcrypt i pozniej juz reci z gorki same bledy
(cached) gcc3checking for libmcrypt-config... /usr/local/bin/libmcrypt-configchecking for libmcrypt - version >= 2.5.0... yeschecking for mhash_keygen in -lmhash... yeschecking whether mhash >= 0.8.15... noconfigure: error: "You need at least libmhash 0.8.15 to compile this program. http://mhash.sf.net/"

rozwiazanie tego problemy w lini komendy wystarczy wstawic ta linike i juz wszystko sie pieknie kopiluje export LD_LIBRARY_PATH=/usr/local/lib pozdrawiam i sprawa zamknieta

Ten post edytował sebastianzar 10.08.2007, 14:28:40
Go to the top of the page
+Quote Post
Jacekalex
post 3.01.2008, 13:27:50
Post #63





Grupa: Zarejestrowani
Postów: 17
Pomógł: 0
Dołączył: 3.11.2007

Ostrzeżenie: (0%)
-----


Witam

U mnie na ubuntu bez problemu działa Apache 2.2.4 z obsługą PHP i wszystkimi modułami.
Włącznie z zabezpieczeniami - mod-security, mod-evasive, mod-apparmor, mod-rewrite.
Zainstalowałem go wg. przepisu : http://ubuntuguide.org/wiki/Ubuntu:Feisty_...wer_HTTP_Apache.
Trzeba sie trochę pomęczyć z konfiguracją modułów - ale nie ma rzeczy niemożliwych.
Czasami po instalacji nie chce chodzić PHP - na forum.ubuntu.pl znajdziesz chyba z 50 sposobów na ten problem.

Mam teraz Gutsy - 7.10 i wszystko śmiga - z drobnymi problemami - nie działa kontrola dostępu (nie wiem jeszcze - jak to uruchomić- przekopałem kilka "pewnych sposobów" - i nic), oraz zapisywanie logów do mysql.
NIe działa też moduł GeoIP - ma jakiś błąd.

Na forum ubuntu widziałem też (w dziale HOWTO ) przepis na kompilacje Apacha 2.2.6 i Php 5 ze źródeł - też działa - ale nie chciało mi się kompilować modułów - więc zostałem przy 2.2.4.

Również dlatego - ze na stronieApache.org poczytałem o odkrytych błędach w poszczególnych wersjach Apacha - 2.2.4 miał ich najmniej.

A startuje z tymi kilkoma modułami:

Loaded Modules:
mod_vhost_alias.c, mod_unique_id.c, mod_status.c, mod_ssl.c, mod_speling.c, mod_speedycgi2.c, mod_setenvif.c, mod_scgi.c, mod_rewrite.c, mod_php5.c, mod_perl.c, mod_neko.c, mod_negotiation.c, mod_python.c, mod_security2.c, mod_evasive20.c, mod_mime_magic.c, mod_mime.c, mod_log_sql_mysql.c, mod_log_sql.c, mod_log_forensic.c, mod_info.c, mod_include.c, mod_ident.c, mod_headers.c, mod_fastcgi.c, mod_env.c, mod_dir.c, mod_cgi.c, mod_autoindex.c, mod_authz_user.c, mod_authz_host.c, mod_authz_groupfile.c, mod_authz_default.c, mod_authn_file.c, mod_auth_sys_group.c, mod_auth_radius-2.0.c, mod_auth_pam.c, mod_auth_mysql.c, mod_auth_basic.c, mod_apparmor.c, mod_alias.c, mod_actions.c, mod_so.c, http_core.c, prefork.c, mod_logio.c, mod_log_config.c, core.c

Pozdrawiam i Dosiego Roku!

Ten post edytował Jacekalex 3.01.2008, 14:06:01
Go to the top of the page
+Quote Post
olszam
post 22.07.2012, 18:28:32
Post #64





Grupa: Zarejestrowani
Postów: 313
Pomógł: 20
Dołączył: 20.01.2011
Skąd: Chełm

Ostrzeżenie: (0%)
-----


Ja to już nie wiem co sie dzieje zainstalowałem to co trzeba a tu nadal coś nie tak, odpalam komende w terminalu "sudo /etc/init.d/apache2 restart" i mam następujący komunikat
Cytat
Starting web server apache2 apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
httpd (pid 15438) already running

nie wiem juz co z tym robić bo już zapomniałem jak skonfigurować plik apache2.conf, adres 127.0.0.1 czy tam 127.0.1.1 to działa, co do phpmyadmina to już odtworzyłem tylko dowiązanie musiałem zrobić
Cytat
sudo ln -s /usr/share/phpmyadmin /var/www/phpmyadmin


Ten post edytował olszam 22.07.2012, 19:05:11
Go to the top of the page
+Quote Post

4 Stron V  « < 2 3 4
Reply to this topicStart new topic
4 Użytkowników czyta ten temat (4 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 22.10.2018 - 11:27