Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> [PHP] 2x require w tym samym "pliku"
virVP
post 26.03.2010, 11:39:36
Post #1





Grupa: Zarejestrowani
Postów: 7
Pomógł: 0
Dołączył: 22.03.2010

Ostrzeżenie: (0%)
-----


Mam problem z podwójnym wywołaniem require("plik.php"); sam plik.php ma taką zawartość:
  1. <?php
  2. function connection() {
  3. $mysql_server = "127.0.0.1:3306";
  4. $mysql_admin = "______";
  5. $mysql_pass = "______";
  6. $mysql_db = "______";
  7.  
  8. @mysql_connect($mysql_server, $mysql_admin, $mysql_pass)
  9. or die('Brak połączenia z serwerem MySQL.');
  10.  
  11. @mysql_select_db($mysql_db)
  12. or die('Błąd wyboru bazy danych.');
  13. }
  14. ?>


Problem pojawia się jak mam taką konstrukcję gdzie:
a.php zawiera w sobie require("plik.php");
b.php zawiera w sobie require("plik.php");

c.php zawiera w sobie require("a.php"); <kod> require("b.php");

Po przetworzeniu część kodu (do miejsca gdzie w b.php odwołuję się do plik.php) system kończy pracę i nie przetwarza w ogóle pliku b.php. Jeśli z b.php usunę require("plik.php"); kod przetwarza się poprawnie. Problem polega na tym,że w innym miejscu używam samodzielnie b.php.

Czy i jak mogę sprawdzić czy plik.php jest już wczytany i pominąć jego ponownie ładowania?
Go to the top of the page
+Quote Post
nospor
post 26.03.2010, 11:41:09
Post #2





Grupa: Moderatorzy
Postów: 34 718
Pomógł: 5772
Dołączył: 27.12.2004




require_once()
Ale przeciez jest to dokladnie w manualu opisane. Zaglądaj tam


--------------------

Najlepsze kawałki programistyczne || Dowcipy o informatykach || Forum PHP dla opornych
Klasy: Pager (stronicowanie) | Cache | ShoutBox (Chat) | Widok | Ładne url'e

"Myśl, myśl, myśl..." - Kubuś Puchatek || "Manual, manual, manual..." - Kubuś Programista
"Szukaj, szukaj, szukaj..." - Kubuś Odkrywca || "Debuguj, debuguj, debuguj..." - Kubuś Developer

Go to the top of the page
+Quote Post
virVP
post 26.03.2010, 12:33:21
Post #3





Grupa: Zarejestrowani
Postów: 7
Pomógł: 0
Dołączył: 22.03.2010

Ostrzeżenie: (0%)
-----


Dzięki:) teraz wszystko działa OK.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 17.09.2019 - 02:05