Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> Postgres automatic failover repmgr
Ken
post 2.03.2020, 15:13:13
Post #1





Grupa: Zarejestrowani
Postów: 4
Pomógł: 0
Dołączył: 2.03.2020

Ostrzeżenie: (0%)
-----


Cześć

używam narzędzia repmgr do automatycznego failovera i systemu ubuntu. Wszystko skonfigurowałem zgodnie z artykułem:
https://www.2ndquadrant.com/en/blog/how-to-...-repmgr-part-1/ - część 1
https://www.2ndquadrant.com/en/blog/how-to-...-repmgr-part-2/ - część 2

wszystko skonfigurowałem klaster, nodes co pokazuje konfiguracja
https://www.dropbox.com/s/euvhdloeoiqu9yl/1.png?dl=0

Następnie jeśli chcę już włączyć daemona po jakimś czasie wywala sie błędem który wygląda następująco:
https://www.dropbox.com/s/p29fp2iigxqvca3/2.png?dl=0

Dlaczego nie mogę uruchomic repmgr? Jeśli jest potrzebna konfiguracja to moge udostępnić

Pozdrawiam
Go to the top of the page
+Quote Post
Pyton_000
post 2.03.2020, 18:22:44
Post #2





Grupa: Zarejestrowani
Postów: 7 983
Pomógł: 1400
Dołączył: 26.10.2005

Ostrzeżenie: (0%)
-----


A co mówią logi dla repmgr ?
Go to the top of the page
+Quote Post
Ken
post 3.03.2020, 09:38:21
Post #3





Grupa: Zarejestrowani
Postów: 4
Pomógł: 0
Dołączył: 2.03.2020

Ostrzeżenie: (0%)
-----


Logi nic nie mówią, nic nie zdążyły zarejestrować.

Daemona nie mogłem uruchomić ponieważ należało zmienić konfigurację w repmgr, mianowicie w pliku /etc/default/Repmgrd trzeba dodać:
REPMGRD_ENABLED=yes
REPMGRD_CONF="/etc/repmgr.conf"

po tej modyfikacji daemon zaczął działać


Dzięki za zainteresowanie Pyton_000

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 20.01.2021 - 04:58