Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> Uwierzytelnianie hasłem SHA256
ReBeLs513
post 11.07.2019, 20:50:53
Post #1





Grupa: Zarejestrowani
Postów: 222
Pomógł: 0
Dołączył: 14.03.2010
Skąd: Dessau

Ostrzeżenie: (0%)
-----


Jak w temacie. Czy mógłby ktoś wytłumaczyć, jak to włączyć?
Ogólnie jak włączę tą metodę to się nie mogę zalogować. Zastanawiam się, co trzeba edytować i gdzie, aby to zadziałało?
kiedy próbuję tego w konsoli mysql w phpmyadmin
[MYSQL] pobierz, plaintext
  1. 51&q=CREATE&lr=lang_en">CREATE 5.1/en/information-functions.html">USER 'admin'@'localhost' IDENTIFIED 51&q=WITH&lr=lang_en">WITH 'caching_sha2_password' 51&q=AS&lr=lang_en">AS '8C6976E5B5410415BDE908BD4DEE15DFB167A9C873FC4BB8A81F6F2AB448A918'
[MYSQL] pobierz, plaintext

to wyskakuje mi błąd "#1524 - Plugin 'caching_sha2_password' is not loaded"

A kiedy zmieniam logowanie w mysql.ini z native na sha2 to mi się serwer nie odpala.

Ten post edytował ReBeLs513 11.07.2019, 21:30:54


--------------------
Przypomnij o "+", jeśli mi pomogłeś a nie zapunktowałem :P
Go to the top of the page
+Quote Post
Pyton_000
post 11.07.2019, 21:30:58
Post #2





Grupa: Zarejestrowani
Postów: 7 799
Pomógł: 1373
Dołączył: 26.10.2005

Ostrzeżenie: (0%)
-----


A logi co mówią?
Go to the top of the page
+Quote Post
ReBeLs513
post 11.07.2019, 21:35:57
Post #3





Grupa: Zarejestrowani
Postów: 222
Pomógł: 0
Dołączył: 14.03.2010
Skąd: Dessau

Ostrzeżenie: (0%)
-----


Kod
[Thu Jul 11 22:17:31.119523 2019] [mpm_winnt:notice] [pid 4824:tid 712] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Thu Jul 11 22:17:33.132424 2019] [mpm_winnt:notice] [pid 8764:tid 572] AH00364: Child: All worker threads have exited.
[Thu Jul 11 22:17:33.491200 2019] [mpm_winnt:notice] [pid 4824:tid 712] AH00430: Parent: Child process 8764 exited successfully.
[Thu Jul 11 22:17:37.539862 2019] [ssl:warn] [pid 16088:tid 704] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 11 22:17:37.742739 2019] [mpm_winnt:notice] [pid 16088:tid 704] AH00455: Apache/2.4.37 (Win64) OpenSSL/1.1.1a PHP/7.2.14 configured -- resuming normal operations
[Thu Jul 11 22:17:37.742739 2019] [mpm_winnt:notice] [pid 16088:tid 704] AH00456: Apache Lounge VC15 Server built: Nov 21 2018 11:51:35
[Thu Jul 11 22:17:37.742739 2019] [core:notice] [pid 16088:tid 704] AH00094: Command line: 'C:\\Users\\norbe\\wamp64\\bin\\apache\\apache2.4.37\\bin\\httpd.exe -d C:/Users/norbe/wamp64/bin/apache/apache2.4.37'
[Thu Jul 11 22:17:37.747734 2019] [mpm_winnt:notice] [pid 16088:tid 704] AH00418: Parent: Created child process 12700
[Thu Jul 11 22:17:38.646178 2019] [ssl:warn] [pid 12700:tid 660] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 11 22:17:38.705144 2019] [mpm_winnt:notice] [pid 12700:tid 660] AH00354: Child: Starting 64 worker threads.
[Thu Jul 11 22:18:31.224525 2019] [mpm_winnt:notice] [pid 16088:tid 704] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Thu Jul 11 22:18:33.225133 2019] [mpm_winnt:notice] [pid 12700:tid 660] AH00364: Child: All worker threads have exited.
[Thu Jul 11 22:18:33.254158 2019] [mpm_winnt:notice] [pid 16088:tid 704] AH00430: Parent: Child process 12700 exited successfully.
[Thu Jul 11 22:18:39.424615 2019] [ssl:warn] [pid 3524:tid 612] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 11 22:18:39.477583 2019] [mpm_winnt:notice] [pid 3524:tid 612] AH00455: Apache/2.4.37 (Win64) OpenSSL/1.1.1a PHP/7.2.14 configured -- resuming normal operations
[Thu Jul 11 22:18:39.477583 2019] [mpm_winnt:notice] [pid 3524:tid 612] AH00456: Apache Lounge VC15 Server built: Nov 21 2018 11:51:35
[Thu Jul 11 22:18:39.477583 2019] [core:notice] [pid 3524:tid 612] AH00094: Command line: 'C:\\Users\\norbe\\wamp64\\bin\\apache\\apache2.4.37\\bin\\httpd.exe -d C:/Users/norbe/wamp64/bin/apache/apache2.4.37'
[Thu Jul 11 22:18:39.484578 2019] [mpm_winnt:notice] [pid 3524:tid 612] AH00418: Parent: Created child process 16532
[Thu Jul 11 22:18:40.269093 2019] [ssl:warn] [pid 16532:tid 608] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 11 22:18:40.327059 2019] [mpm_winnt:notice] [pid 16532:tid 608] AH00354: Child: Starting 64 worker threads.
[Thu Jul 11 22:21:37.315520 2019] [mpm_winnt:notice] [pid 3524:tid 612] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Thu Jul 11 22:21:39.316997 2019] [mpm_winnt:notice] [pid 16532:tid 608] AH00364: Child: All worker threads have exited.
[Thu Jul 11 22:21:39.343759 2019] [mpm_winnt:notice] [pid 3524:tid 612] AH00430: Parent: Child process 16532 exited successfully.
[Thu Jul 11 22:21:58.241797 2019] [ssl:warn] [pid 12960:tid 700] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 11 22:21:58.444674 2019] [mpm_winnt:notice] [pid 12960:tid 700] AH00455: Apache/2.4.37 (Win64) OpenSSL/1.1.1a PHP/7.2.14 configured -- resuming normal operations
[Thu Jul 11 22:21:58.444674 2019] [mpm_winnt:notice] [pid 12960:tid 700] AH00456: Apache Lounge VC15 Server built: Nov 21 2018 11:51:35
[Thu Jul 11 22:21:58.444674 2019] [core:notice] [pid 12960:tid 700] AH00094: Command line: 'C:\\Users\\norbe\\wamp64\\bin\\apache\\apache2.4.37\\bin\\httpd.exe -d C:/Users/norbe/wamp64/bin/apache/apache2.4.37'
[Thu Jul 11 22:21:58.448671 2019] [mpm_winnt:notice] [pid 12960:tid 700] AH00418: Parent: Created child process 7460
[Thu Jul 11 22:21:59.285154 2019] [ssl:warn] [pid 7460:tid 528] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Jul 11 22:21:59.340121 2019] [mpm_winnt:notice] [pid 7460:tid 528] AH00354: Child: Starting 64 worker threads.


Ten post edytował ReBeLs513 11.07.2019, 21:37:08


--------------------
Przypomnij o "+", jeśli mi pomogłeś a nie zapunktowałem :P
Go to the top of the page
+Quote Post
Pyton_000
post 12.07.2019, 07:40:41
Post #4





Grupa: Zarejestrowani
Postów: 7 799
Pomógł: 1373
Dołączył: 26.10.2005

Ostrzeżenie: (0%)
-----


Pokazałeś logi apache co jedno z drugi nie wiele ma do gadania.
Go to the top of the page
+Quote Post
ReBeLs513
post 12.07.2019, 09:08:17
Post #5





Grupa: Zarejestrowani
Postów: 222
Pomógł: 0
Dołączył: 14.03.2010
Skąd: Dessau

Ostrzeżenie: (0%)
-----


w logach mam tylko access, apache-error, maria_db, php_error. nie mam mysql pliku z godziny 22. a po zmianie w mysql ini z native na sha256 to serwer nie chce wstać. natomiast nie pojawia się żaden blad w logu mysql.


--------------------
Przypomnij o "+", jeśli mi pomogłeś a nie zapunktowałem :P
Go to the top of the page
+Quote Post
sazian
post 12.07.2019, 16:33:16
Post #6





Grupa: Zarejestrowani
Postów: 1 011
Pomógł: 137
Dołączył: 19.09.2006
Skąd: B-tów

Ostrzeżenie: (0%)
-----


maria_db to w uproszczeniu mysql
Go to the top of the page
+Quote Post
ReBeLs513
post 13.07.2019, 22:49:38
Post #7





Grupa: Zarejestrowani
Postów: 222
Pomógł: 0
Dołączył: 14.03.2010
Skąd: Dessau

Ostrzeżenie: (0%)
-----


Ale ja pytam o logowanie przy użyciu sha256 w mysql, nie mariadb...


--------------------
Przypomnij o "+", jeśli mi pomogłeś a nie zapunktowałem :P
Go to the top of the page
+Quote Post
viking
post 14.07.2019, 08:05:18
Post #8





Grupa: Zarejestrowani
Postów: 5 279
Pomógł: 889
Dołączył: 30.08.2006

Ostrzeżenie: (0%)
-----


No skoro masz logi z mariadb to chyba oczywiste że używasz mariadb a nie mysql. Trzeba było zainstalować ręcznie to chociaż byś wiedział z czego korzystasz.


--------------------
Go to the top of the page
+Quote Post
ReBeLs513
post 14.07.2019, 11:39:07
Post #9





Grupa: Zarejestrowani
Postów: 222
Pomógł: 0
Dołączył: 14.03.2010
Skąd: Dessau

Ostrzeżenie: (0%)
-----


KORZYSTAM z MYSQL. Poczytaj w google co to wamp i potem się wypowiadaj! Nie wyłaczam mariadb, bo wtedy nie wiem kiedy serwer działa a kiedy nie, bo wszystko jest na żółto. A tak, mariadb sobie jest i serwer jak jest uruchomiony to jest zielony, jak coś się wysypuje, to żółty/ czerwony. A skoro piszę o uwierzytelnianiu sha256 i plikach MYSQL.ini to jasne jest, ze to mysql.
I skoro mariadb działa jako druga baza sql, to oczywiste jest, że jej logi będą widoczne...

WRÓĆMY do tematu!


--------------------
Przypomnij o "+", jeśli mi pomogłeś a nie zapunktowałem :P
Go to the top of the page
+Quote Post
viking
post 14.07.2019, 12:09:22
Post #10





Grupa: Zarejestrowani
Postów: 5 279
Pomógł: 889
Dołączył: 30.08.2006

Ostrzeżenie: (0%)
-----


Wamp ma oba pakiety jak zauważyłeś i mogłeś nie wiedzieć z czego korzystasz. Instalacja bazy oddzielnie to kilka klików. Nie trzeba żadnych pakietów. Być może masz starą wersję która nie działa poprawnie. Mariadb ma tak samo nazwane pliki konfiguracyjne więc nazwy plików nic tu nie mówią. Odpal konsolę mysql i pokaż select version().


--------------------
Go to the top of the page
+Quote Post
Pyton_000
post 14.07.2019, 12:59:38
Post #11





Grupa: Zarejestrowani
Postów: 7 799
Pomógł: 1373
Dołączył: 26.10.2005

Ostrzeżenie: (0%)
-----


https://dev.mysql.com/doc/refman/5.7/en/sha...entication.html
Go to the top of the page
+Quote Post
ReBeLs513
post 14.07.2019, 13:13:08
Post #12





Grupa: Zarejestrowani
Postów: 222
Pomógł: 0
Dołączył: 14.03.2010
Skąd: Dessau

Ostrzeżenie: (0%)
-----


wszystko mam aktualne, wczoraj robiłem update, wiec podskoczyly mi wersje apache, adminer, sysinfo, php, phpmyadmin i mysql własnie. mariadb nie aktualizowałem, bo nie korzystam ;d
mysql mam 5.7.24. Do wyboru tez 8.0.16 po aktualizacji.
"Your MySQL connection id is 2
Server version: 5.7.24 MySQL Community Server (GPL)"

Cytat(Pyton_000 @ 14.07.2019, 13:59:38 ) *

to właśnie czytałem i nie ogarniam tego. zrobiłem w my.ini tak:
Kod
default_authentication_plugin=caching_sha2_password

i serwer nie wstał.

Ten post edytował ReBeLs513 14.07.2019, 13:17:07


--------------------
Przypomnij o "+", jeśli mi pomogłeś a nie zapunktowałem :P
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 21.08.2019 - 15:20