Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> SSL For Free a problem z Certyfikat nie jest zaufany we wszystkich przeglądarkach internetowych
rafaelmc
post 4.12.2017, 22:28:47
Post #1





Grupa: Zarejestrowani
Postów: 25
Pomógł: 0
Dołączył: 16.02.2010

Ostrzeżenie: (0%)
-----


Witam
Chciałem sobie przetestować darmowy certyfikat, przejrzałem troszkę filmików na YT, na razie nie chcę płacić za niego.
Chcę podpiąć certyfikat pod panel w nazwa.pl i działa prawidłowo tylko, że jak testuję go przy pomocy tej strony "https://www.sslshopper.com/" to mi pisze "Certyfikat nie jest zaufany we wszystkich przeglądarkach internetowych. Może być konieczne zainstalowanie certyfikatu pośredniego / łańcucha, aby połączyć go z zaufanym certyfikatem głównym. Dowiedz się więcej o tym błędzie."
Jak rozwiązać ten problem questionmark.gif?
Jak przeglądam stronkę to wyskakuje mi zielona kłódka i wszystko prawidłowo działa na Chrome, Firefoxie, Operze, ale już na mobilności nie koniecznie, a jak testuję stronę przy pomocy "https://gtmetrix.com/"
to ten mi sypie errorem:

Analyze your site’s speed and make it faster.
GTmetrix gives you insight on how well your site loads and provides actionable recommendations on how to optimize it.
Analysis Error
The SSL certificate for this site is not trusted in all web browsers
You may have an incorrectly installed SSL certificate. Check your SSL certificate at SSLShopper
Please see our FAQ on how to fix this error.


Go to the top of the page
+Quote Post
sabat24
post 4.12.2017, 23:03:30
Post #2





Grupa: Zarejestrowani
Postów: 152
Pomógł: 24
Dołączył: 13.09.2007

Ostrzeżenie: (0%)
-----


Brak 100% (przez 100% rozumiem dość wysoką, bo realnie nikt nie daje takiej) kompatybilności to "cena" darmowych certyfikatów. Nie wiem, jak to wygląda przekrojowo teraz, ale szukając jakoś 2 lata temu nie znalazłem darmowego certyfikatu, który działałby na każdej nowszej przeglądarce oraz systemie. Obecnie jest już lepiej, bo przykładowo: https://letsencrypt.org/docs/certificate-compatibility/ - który ma dość niezłą kompatybilność, nie jest tylko kompatybilny z Androidem czy Blackbery w podanych wersjach, co nie jest takie złe.

Ten post edytował sabat24 4.12.2017, 23:18:58
Go to the top of the page
+Quote Post
rafaelmc
post 7.12.2017, 22:12:51
Post #3





Grupa: Zarejestrowani
Postów: 25
Pomógł: 0
Dołączył: 16.02.2010

Ostrzeżenie: (0%)
-----


Dzięki.
No właśnie widzę, jednak będzie trzeba się przenieść na wersję płatną...

Ten post edytował rafaelmc 7.12.2017, 22:13:09
Go to the top of the page
+Quote Post
Tomplus
post 8.12.2017, 06:37:11
Post #4





Grupa: Zarejestrowani
Postów: 1 215
Pomógł: 142
Dołączył: 20.03.2005
Skąd: Będzin

Ostrzeżenie: (0%)
-----


LetsEncrypt jest kompatybilny z Androidem, chyba że mówimy o starszych wersjach.
Mam stronę z LE i błąd braku zaufania nie jest wyświetlany na urządzeniach z nowymi androidami (5 <=).
Go to the top of the page
+Quote Post
sabat24
post 8.12.2017, 10:24:49
Post #5





Grupa: Zarejestrowani
Postów: 152
Pomógł: 24
Dołączył: 13.09.2007

Ostrzeżenie: (0%)
-----


Mówimy o starszych wersjach, dlatego dałem link do kompatybilności. Akurat ten certyfikat jest godny polecenia z darmowych moich zdaniem, choć go nie próbowałem osobiście.
Go to the top of the page
+Quote Post
Pyton_000
post 8.12.2017, 10:57:04
Post #6





Grupa: Zarejestrowani
Postów: 7 372
Pomógł: 1303
Dołączył: 26.10.2005

Ostrzeżenie: (0%)
-----


Ja posadam i jest ok. W zupełności wystarcza na wszystkie potrzeby. Dodatkowo po nowym roku mają wprowadzić jeszcze certyfikat wildcard więc to też będzie jeszcze mega uproszczenie.
Go to the top of the page
+Quote Post
rafaelmc
post 13.12.2017, 22:34:08
Post #7





Grupa: Zarejestrowani
Postów: 25
Pomógł: 0
Dołączył: 16.02.2010

Ostrzeżenie: (0%)
-----


to zabieram się za LetsEncrypt, zobaczę jak to będzie działać...
Dzięki za pomoc...
A bawił się ktoś tym, żeby podpiąć pod nazwa.pl questionmark.gif?
Bo jak się ma CPanel to nie ma problemu...


Ten post edytował rafaelmc 13.12.2017, 23:32:51
Go to the top of the page
+Quote Post
Tomplus
post 14.12.2017, 10:28:29
Post #8





Grupa: Zarejestrowani
Postów: 1 215
Pomógł: 142
Dołączył: 20.03.2005
Skąd: Będzin

Ostrzeżenie: (0%)
-----


nazwa.pl nie oferuje na hostingach LetsEncrypt, chyba że się zmieniło, ale wątpię. Sami oferują tani certyfikat z 8 zł.
Chyba że masz od nich VPS, to nie ma problemu z instalacją LE.
Go to the top of the page
+Quote Post
rafaelmc
post 14.12.2017, 23:08:05
Post #9





Grupa: Zarejestrowani
Postów: 25
Pomógł: 0
Dołączył: 16.02.2010

Ostrzeżenie: (0%)
-----


I tak właśnie myślałem, zostaje mi tylko kupno...
Dzięki.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 20.06.2018 - 10:22