Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> Ebay API, token nie działa
robert0770
post 7.02.2019, 14:16:11
Post #1





Grupa: Zarejestrowani
Postów: 41
Pomógł: 1
Dołączył: 18.02.2015

Ostrzeżenie: (0%)
-----


cześć, chce napisać aplikacje która będzie wystawiać oferty na ebayu z mojej bazy danych (korzystam z DTS\eBaySDK)

Wg tego:
sandbox.ebay.com

-stworzyłem konto na sandoboxie
-utworzyłem User Token (mam appId, cientId, devId)

i do tego momentu wszystko dobrze; pobrało mi czas z serwera

przyszła porta na TradingService

więc testuje to:

https://github.com/davidtsadler/ebay-sdk-ex...y-hierarchy.php

różnica miedzy moim kodem a tym jest tylko tutaj (bo korzystam z sandboxa):

  1. $service = new Services\TradingService(
  2. [
  3. 'credentials' => $config['sandbox']['credentials'],
  4. 'sandbox' => true,
  5. 'siteId' => Constants\SiteIds::PL
  6. ]
  7. );


ale cały czas dostaje:

Error: Auth token is invalid.
Validation of the authentication token in API request failed.

Token pobrałem klikając w "Get OAuth Application Token" przed wybrałem "Auth'n'Auth"
stąd:
https://developer.ebay.com/DevZone/account/tokens/?index=0

dlaczego to nie działa?

oraz pytanie dodatkowe czy za każdym razem jak będę chciał wystawiać aukcje na ebay to bede musiał generować nowy token(czy jest możliwość wygenerowania jakiegoś lifetime?)? bo nawet przy generacji jest napisane:
Expires: Wed, 06 Feb 2019 18:42:42 GMT
czyli na 2 godziny....

ok temat można zamknąć sprawa rozwiązana, myślałem ze konto developera i sandboxowe to te same 2 konta ale trzeba było się zarejestrować jeszcze na sandboxie i dopiąć te konto do konta developerskiego i wtedy wygenerował sie authCode na 1.5 roku

potrzebny był sen jednak żeby to rozwiązać smile.gif

pozdrawiam
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 24.02.2019 - 06:55