Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> Problem z ładowaniem stronku po aktualizacji PHP
wojtasma
post 13.02.2020, 22:31:16
Post #1





Grupa: Zarejestrowani
Postów: 1
Pomógł: 0
Dołączył: 13.02.2020

Ostrzeżenie: (0%)
-----


Witam,

Proszę o pomoc , aktualizowałem PHP z 5.4 na 7.4 i mam problem z ładowaniem jednej podstrony przy poniższym kodzie

require ("../application/connectmysql.ini.php");

$query=("SELECT * from dostawcy WHERE `DOST_Active` = '1' ORDER BY DOST_Nazwa ASC ");
$w=mysql_query($query);

$dost=array();
while($wiersz=mysql_fetch_array($w))
{
$dost[$wiersz[DOST_Id]]=$wiersz[DOST_Nazwa];
}

Czy jest jakieś szybkie rozwiązanie na poprawę?

plik connectmysql.ini.php

<?

require ("config/config.inc");

$login=$_POST["login"];
$password=$_POST["password"];


$link=mysql_connect("$mysql_ip", "$mysql_user", "$mysql_password_user");
$flag=mysql_select_db("$mysql_db");
if(!$link || !$flag){
print("Problem z po_±czeniem z baz± danych");
return false;
}
?>
Go to the top of the page
+Quote Post
viking
post 14.02.2020, 06:10:29
Post #2





Grupa: Zarejestrowani
Postów: 5 483
Pomógł: 932
Dołączył: 30.08.2006

Ostrzeżenie: (0%)
-----


https://prophp.pl/advice/show/3/korzystam_z...ed._dlaczego%3F


--------------------
Go to the top of the page
+Quote Post
dublinka
post 14.02.2020, 08:17:51
Post #3





Grupa: Zarejestrowani
Postów: 404
Pomógł: 51
Dołączył: 22.02.2008

Ostrzeżenie: (0%)
-----


Cytat(wojtasma @ 13.02.2020, 21:31:16 ) *
Witam,

Proszę o pomoc , aktualizowałem PHP z 5.4 na 7.4 i mam problem z ładowaniem jednej podstrony przy poniższym kodzie

require ("../application/connectmysql.ini.php");

$query=("SELECT * from dostawcy WHERE `DOST_Active` = '1' ORDER BY DOST_Nazwa ASC ");
$w=mysql_query($query);

$dost=array();
while($wiersz=mysql_fetch_array($w))
{
$dost[$wiersz[DOST_Id]]=$wiersz[DOST_Nazwa];
}

Czy jest jakieś szybkie rozwiązanie na poprawę?

plik connectmysql.ini.php

<?

require ("config/config.inc");

$login=$_POST["login"];
$password=$_POST["password"];


$link=mysql_connect("$mysql_ip", "$mysql_user", "$mysql_password_user");
$flag=mysql_select_db("$mysql_db");
if(!$link || !$flag){
print("Problem z po_±czeniem z baz± danych");
return false;
}
?>

Zmien na mysqli
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 17.02.2020 - 03:06