Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> PHP nie odbiera ajaxa
temakan
post 30.05.2018, 01:07:17
Post #1





Grupa: Zarejestrowani
Postów: 6
Pomógł: 0
Dołączył: 26.04.2017

Ostrzeżenie: (0%)
-----


Może mi ktoś powiedzieć dlaczego moge pobrać dane, ale wysłac już nie?
  1. <script>
  2. $.post("test3.php",
  3. {
  4. name: "Donald Duck",
  5. city: "Duckburg"
  6. });
  7.  
  8.  
  9. $.post("test3.php", function(data){
  10. alert("Data: " + data);
  11. }
  12. </script>


PHP nie chce tego odebrać
  1. <?php
  2. echo "XD";
  3. echo $_POST["name"];
  4.  
  5. ?>


Ten post edytował temakan 30.05.2018, 01:07:47
Go to the top of the page
+Quote Post
aras785
post 30.05.2018, 10:05:17
Post #2





Grupa: Zarejestrowani
Postów: 763
Pomógł: 150
Dołączył: 29.10.2009

Ostrzeżenie: (0%)
-----


Pewnie, że Ci powiem smile.gif

Twój skrypt który wysyła dane, działa poprawnie. Dane są wysyłane.
  1. $.post("test3.php",
  2. {
  3. name: "Donald Duck",
  4. city: "Duckburg"
  5. });


Ale nigdzie nie przechywtujesz danych które skrypt test3.php wyświetla. Powinno być tak:
  1. $.post("test3.php",
  2. {
  3. name: "Donald Duck",
  4. city: "Duckburg"
  5. }, function(data) {
  6. alert(data);
  7. });


Drugi skrypt również działa ale plik test3.php wywala błędy bo nie przesyłasz $_POST["name"].

Go to the top of the page
+Quote Post
temakan
post 30.05.2018, 11:17:52
Post #3





Grupa: Zarejestrowani
Postów: 6
Pomógł: 0
Dołączył: 26.04.2017

Ostrzeżenie: (0%)
-----


Cytat(aras785 @ 30.05.2018, 11:05:17 ) *
Pewnie, że Ci powiem smile.gif

Twój skrypt który wysyła dane, działa poprawnie. Dane są wysyłane.
  1. $.post("test3.php",
  2. {
  3. name: "Donald Duck",
  4. city: "Duckburg"
  5. });


Ale nigdzie nie przechywtujesz danych które skrypt test3.php wyświetla. Powinno być tak:
  1. $.post("test3.php",
  2. {
  3. name: "Donald Duck",
  4. city: "Duckburg"
  5. }, function(data) {
  6. alert(data);
  7. });


Drugi skrypt również działa ale plik test3.php wywala błędy bo nie przesyłasz $_POST["name"].

Dzięki
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 24.08.2019 - 14:56