Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

> Zasady panujące na forum News

1. Posty w tym forum są poddawane moderacji więc nie dodawaj ich kilka razy.
2. Akceptujemy tylko wartościowe wiadomości o php lub pochodnych
3. Publikacja newsa na wortalu po moderacji oscyluje w granicach 30min
4. Wstawiane grafiki powinny mieć maksymalną szerokość 357px

Zapraszamy do uzupełniania wortalu o ciekawe informacje :)

 
Reply to this topicStart new topic
> Nowe jQuery 2.0 kończy ze wsparciem dla starego Internet Explorera
Spawnm
post 21.04.2013, 10:09:07
Post #1





Grupa: Moderatorzy
Postów: 4 069
Pomógł: 497
Dołączył: 11.05.2007
Skąd: Warszawa




Rozmaite akcje edukacyjne Microsoftu, mające na celu posłanie starych wersji Internet Explorera na cmentarzysko martwego oprogramowania, wciąż nie przynoszą takich efektów, jak byśmy chcieli, wciąż programistów męczy się koniecznością dbania o zgodność serwisów internetowych z IE8 a nawet wcześniejszymi. A jeśli takiej zgodności nie dałoby się już w miarę łatwo zapewnić?

Wydana właśnie wersja 2.0 jQuery, najpopularniejszej biblioteki JavaScriptu na świecie (ocenia się, że korzysta z niej ponad 55 procent serwisów WWW), kończy właśnie z Internet Explorerem 8 i wcześniejszymi wersjami. Autorzy, uważając że dla przeglądarek tych nie ma miejsca we współczesnym WWW, usunęli cały kod odpowiadający za wsparcie tych browserów, uzyskując w efekcie wersję szybszą, mniejszą i wolną od problemów, jakie przynosiła konieczność zapewnienia kompatybilności z IE.

http://www.dobreprogramy.pl/Nowe-jQuery-2....nosc,40759.html
Go to the top of the page
+Quote Post
mstraczkowski
post 22.04.2013, 00:11:25
Post #2





Grupa: Zarejestrowani
Postów: 273
Pomógł: 52
Dołączył: 3.02.2013
Skąd: Przemyśl

Ostrzeżenie: (0%)
-----


Moim zdaniem bardzo dobra decyzja, tylko teraz niech jeszcze normalni klienci do tego dojdą, że kompatybilność nowych stron z IE 6 nie jest aktualnie potrzebna.


--------------------
Jeżeli moja wypowiedź Ci pomogła użyj przycisku
Go to the top of the page
+Quote Post
Spawnm
post 22.04.2013, 06:33:50
Post #3





Grupa: Moderatorzy
Postów: 4 069
Pomógł: 497
Dołączył: 11.05.2007
Skąd: Warszawa




Normalni klienci to wiedzą, od dawien dawna wsadzam na strony css rgba i problemu nigdy nie mam smile.gif
Go to the top of the page
+Quote Post
wwwplugin
post 22.04.2013, 07:34:33
Post #4





Grupa: Zarejestrowani
Postów: 3
Pomógł: 0
Dołączył: 22.04.2013

Ostrzeżenie: (0%)
-----


ja tam uważam że akurat IE6 to nie problem. z iE8 gorzej bo wg ranking.pl ma 40% wszystkich internet explorerów i 6,5% ogólnie. wg mnie to wciąż jeszcze dość dużo. Wyobraźcie sobie prowadzenie sklepu internetowego i "odsianie" 6% użytkowników...

no ale pozostaje czekać aż 6% zmieni się w 0,...


--------------------
Zapraszam na moją stronę z opisem skryptów dla programistów. http://skrypty.serwisik.com/
Go to the top of the page
+Quote Post
thek
post 22.04.2013, 08:00:44
Post #5





Grupa: Moderatorzy
Postów: 4 362
Pomógł: 714
Dołączył: 12.02.2009
Skąd: Jak się położę tak leżę :D




I chwała im za to... Już od dawna było mówione, że to zrobią, ale w końcu krok został uczyniony smile.gif


--------------------
Najpierw był manual... Jeśli tam nie zawarto słów mądrości to zapytaj wszechwiedzącego Google zadając mu własciwe pytania. A jeśli i on milczy to Twój problem nie istnieje :D
Go to the top of the page
+Quote Post
viking
post 22.04.2013, 08:18:48
Post #6





Grupa: Zarejestrowani
Postów: 4 875
Pomógł: 826
Dołączył: 30.08.2006

Ostrzeżenie: (0%)
-----


Tylko w sumie kto chciał używał Zepto. Większą zaletą tego jquery jest modułowość.


--------------------
Go to the top of the page
+Quote Post
kamil4u
post 22.04.2013, 13:34:23
Post #7





Grupa: Zarejestrowani
Postów: 2 350
Pomógł: 512
Dołączył: 4.01.2009
Skąd: Wrocław / Świdnica

Ostrzeżenie: (0%)
-----


Najprawdopodobniej i tak powstaną( o ile już nie powstały ) plugin-y do jQuery obsługujące stare IE. Więc dla upartych klientów też będzie można szybko naprawić IE smile.gif

Też jestem zadowolony z tego faktu, choć czasami sobie myślę, że moja wiedza na temat różnic w IE( bądź, co bądź nie taka mała ), staje się coraz mniej przydatna i mam poczucie, że moja konkurencyjność w tym zakresie znacznie spadła smile.gif


--------------------
Go to the top of the page
+Quote Post
!*!
post 23.04.2013, 08:35:20
Post #8





Grupa: Zarejestrowani
Postów: 4 298
Pomógł: 447
Dołączył: 16.11.2006

Ostrzeżenie: (0%)
-----


To dobra, a zarazem smutna wiadomość.
Dobra, bo za przystosowanie do IE>8 będzie można zgarnąć o wiele więcej $, zła, bo ilość takich praktyk znacząco spadnie.


--------------------
Nie udzielam pomocy poprzez PW i nie mam GG.
Niektóre języki programowania, na przykład C# są znane z niezwykłej przenośności (kompatybilność ze wszystkimi wersjami Visty jest wiele warta).
Go to the top of the page
+Quote Post
sowiq
post 23.04.2013, 10:50:35
Post #9





Grupa: Zarejestrowani
Postów: 1 890
Pomógł: 338
Dołączył: 14.12.2006
Skąd: Warszawa

Ostrzeżenie: (0%)
-----


Cytat(kamil4u @ 22.04.2013, 14:34:23 ) *
Najprawdopodobniej i tak powstaną( o ile już nie powstały ) plugin-y do jQuery obsługujące stare IE.

Chyba czegoś nie rozumiem. Przecież nikt nikogo na siłę nie pcha do przesiadki na wersję 2.0. Jeśli ktoś ciągle potrzebuje wsparcia dla IE 6/7, to niech zostanie przy jQuery w wersji 1.8/1.9. Już w kilku miejscach spotkałem się z opinią (wręcz żalem!), że przecież niektórzy ciągle będą potrzebowali wsparcia dla "przeglądarek". Ale jakoś nikt nie wpadł na to, że może po prostu zostać przy starszej wersji...


--------------------
Go to the top of the page
+Quote Post
!*!
post 23.04.2013, 11:03:16
Post #10





Grupa: Zarejestrowani
Postów: 4 298
Pomógł: 447
Dołączył: 16.11.2006

Ostrzeżenie: (0%)
-----


@sowiq - to po prostu sraczka wydawnicza, pogoń za numerkami dotyczy nie tylko producentów jQ/przeglądarek, ale i potencjalnych "koderów", bo uważają ze jak jest coś nowego, muszą to mieć.


--------------------
Nie udzielam pomocy poprzez PW i nie mam GG.
Niektóre języki programowania, na przykład C# są znane z niezwykłej przenośności (kompatybilność ze wszystkimi wersjami Visty jest wiele warta).
Go to the top of the page
+Quote Post
viking
post 23.04.2013, 11:16:12
Post #11





Grupa: Zarejestrowani
Postów: 4 875
Pomógł: 826
Dołączył: 30.08.2006

Ostrzeżenie: (0%)
-----


Bo na większości serwerów gdzie pisze się o nowym jquery podawane są szczątkowe informacje. A od dawna zapowiadali że będą równolegle rozwijać 2 linie. Niedługo wydana z poprawkami 1.10 itd a obok linia 2.x.


--------------------
Go to the top of the page
+Quote Post
kamil4u
post 23.04.2013, 12:37:42
Post #12





Grupa: Zarejestrowani
Postów: 2 350
Pomógł: 512
Dołączył: 4.01.2009
Skąd: Wrocław / Świdnica

Ostrzeżenie: (0%)
-----


Osobiście rzadko korzystam z jQuery - dość często piszę w czystym JS. Nie znam wszystkich numerków jQuery, ale z tego co pamiętam wraz z ich wzrostem szły udoskonalenia biblioteki( poprawa algorytmów, nowe funkcje itd. ). Dlatego właśnie zawsze sięgałem po najnowszą wersję. Dlatego w moim przypadku to nie tyle jest przesiadka na nowszą wersje( bo na tyle rzadko z niej korzystam, że trudno żebym się przesiadał ), a po prostu ściągnięcie tego co jest najnowsze.


--------------------
Go to the top of the page
+Quote Post
Dejmien_85
post 23.04.2013, 13:50:05
Post #13





Grupa: Zarejestrowani
Postów: 251
Pomógł: 23
Dołączył: 23.04.2013

Ostrzeżenie: (0%)
-----


I bardzo dobrze zrobili, przydałoby się jeszcze tylko uświadomić zwykłych internautów o tym, aby przesiedli się na nowsze przeglądarki. Ja jestem zwolennikiem "if IE" oraz tekstu o przestarzałym oprogramowaniu - a niech wiedzą, że dużo tracą! ; )

PS Tak w ogóle to witam wszystkich, to mój pierwszy post.
Go to the top of the page
+Quote Post
peter13135
post 24.04.2013, 08:33:08
Post #14





Grupa: Zarejestrowani
Postów: 1 445
Pomógł: 191
Dołączył: 26.03.2008

Ostrzeżenie: (0%)
-----


Cytat(kamil4u @ 23.04.2013, 13:37:42 ) *
Osobiście rzadko korzystam z jQuery - dość często piszę w czystym JS. Nie znam wszystkich numerków jQuery, ale z tego co pamiętam wraz z ich wzrostem szły udoskonalenia biblioteki( poprawa algorytmów, nowe funkcje itd. ). Dlatego właśnie zawsze sięgałem po najnowszą wersję. Dlatego w moim przypadku to nie tyle jest przesiadka na nowszą wersje( bo na tyle rzadko z niej korzystam, że trudno żebym się przesiadał ), a po prostu ściągnięcie tego co jest najnowsze.


Ale rozwijane będę dwie linie 1.x oraz 2.x .
Idąc tym tokiem myślenia, jak najpierw zostanie wydana wersja np 2.2 a potem 1.13 to wersja 1.13 będzie nowsza smile.gif

Myślę, że jeśli programiści jQuery poprawiają jakiś algorytm, w jakimś module, to jeśli jest taka możliwość, poprawią go w obu liniach.

Inaczej mówiąc, to o ile dobrze rozumiem, obie wersje będą "nowe" (tzn, będą równolegle rozwijane) z tym, że wersja 2.0 ma być szybsza i lżejsza kosztem kompatybilności z z starymi IE.


--------------------
:)
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 18.07.2018 - 21:27