Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> Migracja z php5.6 do php7.0
rebadow
post 28.06.2018, 08:38:23
Post #1





Grupa: Zarejestrowani
Postów: 2
Pomógł: 0
Dołączył: 28.06.2018

Ostrzeżenie: (0%)
-----


Dzień dobry,

na serwerze, na którym działa strona wordpress był zainstalowany php5.6. Zaktualizowałem go przez ssh php do wersji 7.0. Niestety sama strona w system status pokazuje PHP Version: 5.6.36-0+deb8u1.

Po aktualizacji usunąłem php5.6 z serwera. Co jeszcze muszę zrobić?
Go to the top of the page
+Quote Post
Tomplus
post 28.06.2018, 09:58:57
Post #2





Grupa: Zarejestrowani
Postów: 1 271
Pomógł: 149
Dołączył: 20.03.2005
Skąd: Będzin

Ostrzeżenie: (0%)
-----


Jeżeli zmieniłeś wersję PHP dla serwera (nie trzeba usuwać poprzedniej wersji) i wordpress wciąż działa, to nie trzeba nic więcej robić.

funkcja PHPINFO() powie ci prawdę jaka jest wersja PHP, a to co jest na Wordpress to mogą być dane serwera zapisane w bazie podczas instalacji.
Go to the top of the page
+Quote Post
rebadow
post 28.06.2018, 23:26:40
Post #3





Grupa: Zarejestrowani
Postów: 2
Pomógł: 0
Dołączył: 28.06.2018

Ostrzeżenie: (0%)
-----


dzięki za odpowiedź już się martwiłem,

na serwerze php -version zwraca PHP 7.0.30-1~dotdeb+8.1 (cli) ( NTS ).

a jednak napiszę tutaj jeszcze raz z prośbą o pomoc. Po utworzeniu pliku phpinfo.php i wejściu na stronę.

Zatytułowany on jest PHP Version 5.6.36-0+deb8u1. a poniżej:

Configuration File (php.ini) Path /etc/php5/apache2
Loaded Configuration File /etc/php5/apache2/php.ini
Scan this dir for additional .ini files /etc/php5/apache2/conf.d


Na serwerze PHP instalowałem z dotdeb.org po dodaniu do sources.list

apt-key add dotdeb.gpg
apt-get update
apt-get install php7.0

po wpisanu php -version -> PHP 7.0.10-1~dotdeb+8.1 (cli) ( NTS )

Przeglądałem katalogi i aktualnie na serwerze są dwa php dla php7.0 i php5. Co mogę zrobić w takiej sytuacji?

Poradziłem sobie w między czasie więc zostawiam rozwiązanie gdyby ktoś podobnie zielony do mnie miał taki sam problem:

sudo a2dismod php5.6
sudo a2enmod php7.0
service apache2 restart

Ten post edytował rebadow 28.06.2018, 23:38:02
Go to the top of the page
+Quote Post
Tomplus
post 29.06.2018, 22:11:36
Post #4





Grupa: Zarejestrowani
Postów: 1 271
Pomógł: 149
Dołączył: 20.03.2005
Skąd: Będzin

Ostrzeżenie: (0%)
-----


Możesz nawet zainstalować wersję 7.2, bo jest już w oficjalnym repo debiana.
Go to the top of the page
+Quote Post
sazian
post 1.07.2018, 11:22:47
Post #5





Grupa: Zarejestrowani
Postów: 994
Pomógł: 133
Dołączył: 19.09.2006
Skąd: B-tów

Ostrzeżenie: (0%)
-----


Tak jest ale w debianie Buster czyli aktualnej wersji testowej.
Jak można zauważyć po wersji pakietu "5.6.36-0+deb8u1" rebadow ma debiana 8 czy Jessie.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 19.12.2018 - 05:04