Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl


_walus
Napisane: 16.03.2017, 13:20:15





Grupa: Zarejestrowani
Postów: 8
Dołączył: 4.09.2009

Ostrzeżenie: (0%)
-----

Dzięki Ci wielkie smile.gif Naprowadziłeś mnie na dobre tory. Przez szukanie rozwiązania w necie i ilości podobnych problemów byłem tak zaślepiony, że utwierdziłem się w przekonaniu, że to wina edytora. Dopiero Ty naprowadziłeś mnie na możliwość błędu z zupełnie innej strony. Dzięki! smile.gif

Ale dla potomnych - jak by ktoś, kiedyś, gdzieś się męczył z problemem wink.gif

Korzystałem w tym projekcie z Codeigniter'a no i na samym początku projektu włączyłem filtrowanie wszystkich danych pod kątem ataków XSS i o nim zapomniałem. I to on powodował taką dziwną zamianę.

No ale to znów jakaś nowa wiedza na przyszłość wink.gif

Pozdrawiam
  Forum: Po stronie przeglądarki · Podgląd postu: #1212599 · Odpowiedzi: 6 · Wyświetleń: 1 077

_walus
Napisane: 16.03.2017, 00:37:07





Grupa: Zarejestrowani
Postów: 8
Dołączył: 4.09.2009

Ostrzeżenie: (0%)
-----

Zrobiłem i faktycznie na podanej przez Ciebie stronie jest tak jak być powinno, ale w rzeczywistości u mnie jest inaczej ;/

Ustawienia mam właśnie standardowe, ale na wszelki wypadek wywaliłem wszystkie i postawiłem gołe. Niestety żadnej poprawy.
Treść formularza jest wysyłana do walidacji, ale jak wcześniej pisałem przechwyciłem tekst przed jakimkolwiek działaniem skryptu PHP i wtedy już jest "obcięty" przez edytor.

Witki opadają. Ale jak tak krążę po necie to widzę, że sporo osób ma ten problem, ale nikt nie zna złotego środka...

Dzięki za zainteresowanie smile.gif
  Forum: Po stronie przeglądarki · Podgląd postu: #1212575 · Odpowiedzi: 6 · Wyświetleń: 1 077

_walus
Napisane: 15.03.2017, 17:07:44





Grupa: Zarejestrowani
Postów: 8
Dołączył: 4.09.2009

Ostrzeżenie: (0%)
-----

Tak jest jak podglądasz kod w edytorze, ale jak podejrzę co wysłał formularz zanim zapiszę treść z tego polo do bazy to pokazuje mi, że ckeditor wygenerował "ziarnko piasku < ziarnko>".
W bazie to wygląda tak: "<p>ziarnko piasku óóó < ziarnko>" - jak by zamiast </p> zrobił tag "<ziarnko>
  Forum: Po stronie przeglądarki · Podgląd postu: #1212544 · Odpowiedzi: 6 · Wyświetleń: 1 077

_walus
Napisane: 15.03.2017, 13:43:31





Grupa: Zarejestrowani
Postów: 8
Dołączył: 4.09.2009

Ostrzeżenie: (0%)
-----

Hej,

Szukam od pewnego czasu rozwiązania mojego problemu, ale niestety nic co by mi pomogło nie znalazłem... Może ktoś z Was miał podobny problem?

Używam na swojej stronie edytora CKeditor w wersji 4.6.2. Ostatnio przez przypadek zauważyłem, że znak mniejszości "<" usuwał treść za nim aż do wciśnięcia "enter".
Po obejrzeniu bazy okazuje się, że CKeditor tworzy z tej treści nowy znacznik przez co w bazie jest to wyświetlane ale już w edytorze czy na stronie nie np wpisując "ziarnko pisaku < ziarnko grochu" w bazie dostajemy "<p>ziarnko pisaku <ziarnkogrochu>".

Miał ktoś może podobny problem?

Pozdrawiam serdecznie
Adam
  Forum: Po stronie przeglądarki · Podgląd postu: #1212534 · Odpowiedzi: 6 · Wyświetleń: 1 077

_walus
Napisane: 23.02.2013, 18:55:51





Grupa: Zarejestrowani
Postów: 8
Dołączył: 4.09.2009

Ostrzeżenie: (0%)
-----

Tylko jest jeden problem to jest już baza istniejącego serwisu i nie bardzo mogę w bazie ingerować - w sensie struktury...
  Forum: Przedszkole · Podgląd postu: #1027886 · Odpowiedzi: 5 · Wyświetleń: 934

_walus
Napisane: 23.02.2013, 18:42:16





Grupa: Zarejestrowani
Postów: 8
Dołączył: 4.09.2009

Ostrzeżenie: (0%)
-----

Przepraszam, że dopiero odpisuję, ale nie miałem czasu się ponownie tym zająć.

Wprowadziłem te zmiany i niestety nie przynosi to zamierzonego efektu sad.gif Nic to nie psuje, ale i nie pomaga... Ma ktoś jeszcze jakieś propozycje?
  Forum: Przedszkole · Podgląd postu: #1027881 · Odpowiedzi: 5 · Wyświetleń: 934

_walus
Napisane: 21.02.2013, 01:22:21





Grupa: Zarejestrowani
Postów: 8
Dołączył: 4.09.2009

Ostrzeżenie: (0%)
-----

Hej.

Przeszukałem forum, ale jakoś nie bardzo znalazłem odpowiedź na moje pytanie...

Mam taki mały problem: mam trzy tabele w bazie:
- artykuly (id_artykul, tytul, kategoria, cośtam...)
- osoby (id_osoba, nazwisko, cośtam...)
- artykuly_osoby (id_artykuly_osoby, id_artykul, id_osoba)

i teraz potrzebuję pobrać artykuły o konkretnej kategorii, które napisały jakieś osoby (w tabeli artykuly_osoby jest powiązanie), ale niektóre artykuły mogą być napisane w formie ulotki, czy zapowiedzi, gdzie nie jest podana osoba, bo tekst nie ma autora jako takiego. Udało mi się napisać zapytanie które wiąże artykuły z osobami i wyświetla te do których jest przypisany autor, ale które nie posiadają autora nie są wyciągane z bazy, a na stronie muszą znaleźć się wszystkie artykuły z danej kategorii (te z autorem jak i bez).

Z góry dziękuję za wszelkie przejawy pomocy smile.gif

Pozdrawiam!
  Forum: Przedszkole · Podgląd postu: #1027230 · Odpowiedzi: 5 · Wyświetleń: 934

_walus
Napisane: 2.08.2010, 08:45:58





Grupa: Zarejestrowani
Postów: 8
Dołączył: 4.09.2009

Ostrzeżenie: (0%)
-----

Z tego co wiem to nie ma takiej możliwości. Musisz ją przenieść na początek kody lub zdeklarować w jakimś pliku który dołączysz do kody, ale to również musi się odbyć przed wywołaniem funkcji...
  Forum: Przedszkole · Podgląd postu: #773255 · Odpowiedzi: 10 · Wyświetleń: 895


New Posts  Nowe odpowiedzi
No New Posts  Brak nowych odpowiedzi
Hot topic  Popularny temat (Nowe)
No new  Popularny temat (Brak nowych)
Poll  Sonda (Nowe)
No new votes  Sonda (Brak nowych)
Closed  Zamknięty temat
Moved  Przeniesiony temat
 

RSS Wersja Lo-Fi Aktualny czas: 21.02.2020 - 22:59