Witaj Gościu! ( Zaloguj | Rejestruj )

Forum PHP.pl

 
Reply to this topicStart new topic
> IIS +PHP + php.ini
dooq
post 28.04.2007, 18:42:17
Post #1





Grupa: Zarejestrowani
Postów: 2
Pomógł: 0
Dołączył: 28.11.2006

Ostrzeżenie: (0%)
-----


Witam. Może mi ktoś pomoże? -
PHP versja 5.1.6 (wersja zip lub msi), instalacja na WIN XP PRO i SBS 2003 Prof dają takie same objawy
Instalacja standardowa PHP w katalogu c:\php. W zmiennych systemowych windowsa do zmiennej PATH dodałem ścieżki do katalogi C:\php; C:\php\ext;.
W konsoli IIS-a -> Witryny sieci web -> Właściwości -> Filtry ISAPI utworzony filtr o nazwie PHP5 (stan "załadowany", Wykonywalny: "C:\php\php5isapi.dll".
W konsoli IIS-a -> Witryny sieci web -> Właściwości -> Katalog macierzysty ustawienia skryptów na "odczyt", Uprawnienia wykonywania: "Tylko sktypty",
W konsoli IIS-a -> Witryny sieci web -> Właściwości -> Katalog macierzysty-> konfiguracja -> mapowanie:
Wykonywalny: "C:\php\php5isapi.dll", rozszeżenie ".php", zaznaczone "Aparat skryptu" oraz "Sprawdź czy plik istnieje". Dodatkowo w SBS 2003 (IIS 6.0) w "rozszerzeniach usług webowych" dodałem nową pozycję, nazwałem ją PHP i jako wymagalny plik dodałem "C:\php\php5isapi.dll".
Wszystko odpaliło, utworzyłem plik index.php, a w nim umieściłem "phpinfo()" (oraz echo "napis test - to jest ważne";). Po wpisaniu w przeglądarce adresu dostaję wynik phpinfo - całą konfigurację (i na końcu "napis test - to jest ważne").
I WSZYSTKO BYŁO BY OK. GDYBY NIE .....
no właśnie w pierwszej ramce (6 linijka) mam:
Configuration File (php.ini) Path C:\WINDOWS questionmark.gifquestionmark.gif? - ja w katalogu c:\windows NIE MAM php.ini (jest w katalogu c:\php)
Jakiekolwiek zmiany w pliku c:\php\php.ini nie są widoczne na powyższej stronie (oczywiście był restart IIS i restart maszyny - nie ma żadnego efektu).
Następnie usuwam pliki php.ini, php.ini-dist, php.ini-recommended z katalogu c:\php, restarty i dalej dostaję standardowy wynik konfiguracji questionmark.gifquestionmark.gif? - skąd?questionmark.gif
I TERAZ NAJWAŻNIEJSZE - kopiuję plik php.ini do katalogu C:\windows i restarty, i po wywołaniu strony index.php nie dostaję nic na ekranie - biały ekran. Wystarczy, że zmienie nazwę pliku c:\windows\php.ini i restart iis-a i wszystko działa - z tym że nie wiem jak skonfigurować PHP.
Go to the top of the page
+Quote Post
suchoparek
post 25.05.2007, 17:10:10
Post #2





Grupa: Zarejestrowani
Postów: 1
Pomógł: 0
Dołączył: 25.05.2007

Ostrzeżenie: (0%)
-----


nie wiem czy to jeszcze aktualne, ale czy sprawdzales czy w katalogu c:\windows plik php.ini ma odpowiednie uprawnienia dostepu do pliku?
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 Użytkowników czyta ten temat (1 Gości i 0 Anonimowych użytkowników)
0 Zarejestrowanych:

 



RSS Wersja Lo-Fi Aktualny czas: 14.11.2019 - 02:15